Network Shares Are Unavailable On The Secondary Server When Active

Follow

Summary

This Knowledgebase article provides information about network shares unavailable on the Secondary server when it becomes active.


More Information

Symptoms

After a switchover/failover from the Primary server to the Secondary (newly active) server, users find that the network shares are no longer visible from remote clients. This problem may be experienced following the first switchover after an install. This problem primarily affects the File Server, however the problems can be experienced accessing shares on Exchange or SQL Server servers.

Clients attempting to browse Network Neighborhood will be refused a connection, the response may state that the:

  • 'Server' service is not running.
  • User does not have permissions to access the network resource.
  • Net use - will fail with a 'System error 67 - network name not found'
  • Net view - will fail with a 'System error 51 - path not found'

Note: This problem may also occur on the Primary server if NetBIOS over TCP/IP is disabled or unbound from the Principal (Public) network adapter.

Cause

This problem can occur on the Primary server if NetBIOS over TCP/IP is disabled or it becomes unbound from the Principal (Public) network adapter. Shares will not be advertised to browsing clients.

Resolution

  1. Check that NetBIOS over TCP/IP is enabled for the Principal (Public) network adapter on both the Primary and Secondary servers.
  2. If Netbios over TCP/IP is enabled then check that it is physically bound to the adapter:

c:\$>net config server

Example output:

Server Name \\MC_NAME
Server Comment

Software version Windows 2000
Server is active on
NetBT_Tcpip_{B1CCE619-3B32-403D-9023-1FCE7C81D78E} (00065bd404e3)
NetbiosSmb (000000000000)


Server hidden No
Maximum Logged On Users Unlimited
Maximum open files per session 16384

Idle session time (min) 15
The command completed successfully

The configuration should state that the server is active on the NetBT_Tcpip_{ this means that it will respond to NetBIOS requests for share information.

Server is active on
NetBT_Tcpip_{B1CCE619-3B32-403D-9023-1FCE7C81D78E} (00065bd404e3)
NetbiosSmb (000000000000)

If it shows only NetbiosSmb then there is a problem with the Network cards and the protocols that are bound to them.

For example:

Server is active on
NetbiosSmb (000000000000)

To resolve this perform the following on the affected server.

  1. Via Network Neighborhood, select 'Properties' on the Public Adapter.
  2. Clear the check box 'File and Printer Sharing for Microsoft Networks'.
  3. Press OK to apply the changes.
  4. Select the 'File and Printer Sharing for Microsoft Networks'.
  5. This should cause the NetBT protocol to rebind to the adapter.

    To confirm this, run the command: c$> net config server

    If that does not show NetBT_Tcpip is bound as per example above proceed to Step 6. Otherwise, check the shares are accessible.
  6. Stop Neverfail Heartbeat.
  7. Uninstall all network cards via Device Manager.
  8. Reboot the server.
  9. Reconfigure all network cards and allow the Neverfail Packet Filter to install. Reboot the server when prompted by Windows.
  10. Check that NetBT_Tcpip is bound using the 'net config' server command.
  11. Clear the check box for the Packet Filter from all NICs EXCEPT the Principal (Public) NIC.


Applies To

All Versions


Related Information

None

KBID-312

0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.