An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full

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Summary

This Knowledgebase article provides details about the error message below:

'An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full'


More Information

Symptoms

Error Message: [ java.io.IOException: An operation on a socket could not be performed because the system lacked sufficient buffer space or because a queue was full ]

Cause

According to Microsoft, this error is frequently related to the number of Free System Page Table Entries (PTE). A level of 8.000 free PTEs is marginal and a level of 5.000 free PTE is critical. Please see the table in the Microsoft TechNet article 998384 http://technet.microsoft.com/en-us/library/aa998384.aspx

Starting with SCOPE V4.2.0, the free PTEs can be found in the SCOPE RAW DATA viewer -> PERFORMANCE DATA -> \Memory\Free Page Table Entries.

For previous versions of SCOPE, the following procedure can be used:

  1. From the Administrative Tools start Perfmon.
  2. In the left side expand the ‘Performance Logs and Alerts’, right-click ‘Counter Logs’ and select ‘New log settings’.
  3. When prompted give a relevant name to the new log (e.g. Free PTEs measured with HB stopped).
  4. In the new dialog which appears, note the path and the name of the log file.
  5. Click ‘Add Counters’.
  6. Select ‘Use local computer counters’.
  7. Select Performance object to be ‘Memory’.
  8. Select ‘Free System Page Table Entries’ and click on the ‘Add’ button.
  9. Close the 'Add Counters' dialog to return to the Log File dialog.
  10. Set the time interval to 3 minutes.
  11. On the 'Log File' tab, select the 'Log File' type to be ‘Text File (Comma separated)’.
  12. From the 'Schedule' tab, you can set the time interval when the counter should be monitored.
Start this new Performance task and let it run for a while, then stop it and analyze the output .CSV file according to Microsoft's TechNet article above.

Resolution

  1. The two actions below can be also used, though they are not guaranteed to fix the problem:
    1. Removing all unused NICs from Device Manager (hidden devices).
    2. Applying the latest drivers for the network adapters.

  2. If the number of free PTEs are at the "Warning" or "Critical" level, some of the drivers installed on the server but not needed should be removed. Neverfail recommends that the video driver is removed and instead the standard one is used.

    Microsoft advice:
    Free Page Table Entries is at Warning threshold
    Free Page Table Entries is at Critical threshold

  3. Where the protected application is Microsoft Exchange 2000 Server, consult Microsoft Knowledge Base article http://support.microsoft.com/kb/313707 .


Applies To

All Versions


Related Information

None

KBID-1102

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