Failure of the Registry to Synchronize When Plug-in for Microsoft Antigen for Exchange is Installed

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Summary

This Knowledgebase article provides information about the failure of the registry to synchronize when the Plug-in for Microsoft Antigen for Exchange is installed on a server running Microsoft Antigen for Exchange.


More Information

Symptom

When the Plug-in for Microsoft Antigen for Exchange is installed on a server running Microsoft Antigen for Exchange, registry synchronization fails to complete.

Cause

The Plug-in for Microsoft Antigen for Exchange will detect all virus scan engines used by Microsoft Antigen for Exchange which are from a variety of different vendors and includes the Kaspersky scan engine. The Plug-in for Microsoft Antigen for Exchange will add protection for the scan engine by protecting the registry key.

Kaspersky Anti-Virus has a feature called ‘self protection’ which monitors access to its own registry keys and prevents access to them by other applications. The self protection feature places a lock on the registry key thereby preventing Neverfail from protecting the key.

Resolution

Note: Installation of plug-ins should only be performed on the active server.

To resolve the issue and allow Plug-in for Microsoft Antigen for Exchange to synchronize the files and registry keys, clear the 'Self Defense' option in Kaspersky on both the Primary and Secondary server and select the 'Password Protection' option. This results in the registry key being unlocked on the passive server and thereby allows for successful synchronization.


Applies To

Plug-in for Microsoft Antigen for Exchange


Related Information

None

KBID-1787

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