How to Upgrade SolarWinds Failover Engine Vx.x to a later version of SolarWinds Failover Engine

Follow

Summary

This Knowledgebase article provides step-by-step procedures to upgrade the below listed versions of SolarWinds Failover Engine to the indicated later versions:

  • v6.0 to v6.2, v6.3.1, v6.5.0, v6.5.1, v6.5.2, v6.6.0, v6.6.1, v6.6.2, or v6.7
  • v6.2 to v6.3.1, v6.5.0, v6.5.1, v6.5.2, v6.6.0, v6.6.1, v6.6.2, or v6.7
  • v6.3.1 to v6.5.0, v6.5.1, v6.5.2, v6.6.0, v6.6.1, v6.6.2, or v6.7
  • v6.5.0 to v6.5.1, v6.5.2 v6.6.0, v6.6.1, v.6.6.2, or v6.7
  • v6.5.1 to v6.5.2, v6.6.0, v6.6.1, v6.6.2, or v6.7
  • v6.5.2 to v6.6.0, v6.6.1, v6.6.2, or v6.7
  • v6.6.0 to v6.6.1, v6.6.2, or v6.7
  • v6.6.1 to v6.6.2, or v6.7
  • v6.6.2 to v6.7

More Information

This procedure assumes that the upgrade process will be performed during a maintenance window.

NOTES:
  • This procedure supports upgrades of a v6.0, v6.2, v6.3.1, v6.5.0, v6.5.1, v6.5.2, v6.6.0, v6.6.1, or v6.6.2 server Pair/Trio to a later version server Pair/Trio. It does not support upgrading from a Pair (two servers) to a Trio (three servers).
  • This procedure assumes that the upgrade process will be performed during a maintenance window.

Upgrade Sequence

  1. Upgrade to .Net 4.0
  2. Uninstall and Reinstall Neverfail SCOPE
  3. Upgrade SolarWinds Failover Engine t o a Later Ver sion
  4. Upgrade Plug-ins

A. Upgrad e to .Net 4.0

Important: SolarWinds Failover Engine Setup requires that you upgrade to .Net 4.0 before SolarWinds Failover Engine vx.x.x or later is installed.

Upgrading to .Net 4.0 with minimum downtime:

Note: The following URL will redirect you to the Microsoft Download Center where you can download .Net Framework Version 4.0

Web Installer - http://www.microsoft.com/download/en/details.aspx?id=17851
Standalone version - http://www.microsoft.com/download/en/details.aspx?displaylang=en&id=17718

  1. Download .Net Framework Version 4.0 to the passive server.

    Note: The above URL provides a link to a version of .Net Framework 4.0 that is redistributable and compatible with both 32bit and 64bit Operating Systems.
  2. Navigate to the download location and run the .Net Framework Version 4.0 dotNetFx40_Full_x86_x64.exe file to start installation.
  3. If asked to restart the passive server, select to restart later.
  4. If upgrade to .Net 4.0 on the passive server fails, investigate the cause and do NOT apply the upgrade to the active server.
  5. If upgrade to .Net 4.0 is successful on the passive server, then upgrade to .Net 4.0 on the active server.
  6. If asked to restart the active server, select to restart later.
  7. If the active or passive server requires a restart, perform the restart during a Controlled Shutdown maintenance window to make use of Fast Check.
  8. Once .Net Framework Version 4.0 has completed installation on both the passive and active servers, run Setup for SolarWinds Failover Engine now or at a later time using the procedures listed above in the Upgrade SolarWinds Failover Engine to a Later Version section.

B. Uninstall and Reinstall Neverfail SCOPE

NOTE:

  • To upgrade Neverfail SCOPE from a pre v5.2.0 to v5.2.0 or later, you must have .Net 4.0 installed on the server. Neverfail SCOPE v5.2.0 will not install unless .Net 4.0 is present. To upgrade to .Net 4.0, see "Upgrade to .Net 4.0" above.

Uninstall the previous version of Neverfail SCOPE Data Collector Service by navigating to Start > Control Panel > Add or Remove Programs > Neverfail SCOPE Data Collector Service . Click Remove to uninstall.

Install the Current Version of Neverfail SCOPE

  1. Download Neverfail SCOPE from the Neverfail Extranet by navigating to Products/Downloads > Neverfail SCOPE and selecting the latest version of SCOPE.
  2. Save the .ZIP installer file to an appropriate location.
  3. Extract the contents of the .ZIP file to a desired location. Read the Readme.txt file for additional information.
  4. Double-click the .exe installer file to start the installation wizard.
  5. Follow the on-screen instructions to complete the installation.

C. Upgrade SolarWinds Failover Engine to a Later Version

NOTES:

  • To upgrade SolarWinds Failover Engine from a pre vx.x.x to vx.x.x. or later, you must have .Net 4.0 installed on the server. SolarWinds Failover Engine vx.x.x will not install unless .Net 4.0 is present. To upgrade to .Net 4.0, see "Upgrade to .Net 4.0" above.
  • This procedure assumes that the Primary server is also the active server.
  • Performing a Service Pack upgrade does not upgrade the System Plug-in. The System Plug-in must be upgraded separately using the procedure provided below under 'Plug-ins Upgrade'.

Perform the following steps to preserve your current configuration settings while upgrading from SolarWinds Failover Engine to a later version of SolarWinds Failover Engine.

  1. Download the intended version of SolarWinds Failover Engine and extract the contents to an appropriate location on the Primary and Secondary servers, and on the Tertiary server if this is present.
  2. From the Primary/active server, stop Neverfail Heartbeat on all servers. You can leave the protected applications running.
  3. Navigate to Start > Administrative Tools > Services and set the Neverfail Server R2 service to manual.
  4. On each passive server, navigate to Start > Administrative Tools > Services and set the Neverfail Server R2 service to manual.
  5. On each passive server, disconnect the network cable from the Principal (Public) NIC.
  6. On the Primary/active server, launch the later version Setup.exe and select Install Service Pack from the Setup Type window.
  7. Follow the on-screen instructions to install the ServicePack.nfs script. When prompted, restart the server.

    Note: When launching Setup.exe you may receive the following message with a Yes or No prompt:

    Some files that this Installer uses are marked as unsafe.

    Do you want to clear the flag(s)?

    Progress is not possible unless the flags are reset.

    YES or NO
    Click Yes to continue.

    Note: During the upgrade process, you may receive Windows warnings that the software being installed has not passed Windows Logo Testing. Please ignore these warnings and press Continue Anyway .

  8. For each passive server, perform the following steps:
    • Launch the later version Setup.exe and select Install Service Pack from the Setup Type window.
    • Follow the on-screen instructions to install the ServicePack.nfs script. When prompted, restart the server.

      Note: When launching Setup.exe you may receive the following message with a Yes or No prompt:

      Some files that this Installer uses are marked as unsafe.

      Do you want to clear the flag(s)?

      Progress is not possible unless the flags are reset.

      YES or NO
      Click Yes to continue.

      Note: During the upgrade process, you may receive Windows warnings that the software being installed has not passed Windows Logo Testing. Please ignore these warnings and press Continue Anyway .

  9. On the Primary/active server, check the configuration of the NICs and make corrections if necessary (the packet filter should be selected on Principal (Public) NICs and cleared on channel NICs).
  10. On each passive server, check the configuration of the NICs and make corrections if necessary (the packet filter should be selected on Principal (Public) NICs and cleared on channel NICs).
  11. On the Primary/active server, start SolarWinds Failover Engine.
  12. On the Primary/active server, navigate to Start > Administrative Tools > Services and set the Neverfail Server R2 service to automatic.
  13. On each passive server, start SolarWinds Failover Engine and reconnect the network cable to the Principal (Public) NIC.
  14. On each passive server, navigate to Start > Administrative Tools > Services and set Neverfail Server R2 service to automatic.

Note: If after installing SolarWinds Failover Engine, a plug-in fails to load and the error message says:

Unable to load plugin XxxxNFPlugin.dll because Method not found...

then there is a version mismatch between the plug-in and the installed version of SolarWinds Failover Engine.  Please use the latest version of SolarWinds Failover Engine software and the latest version of the plug-in. See the section below for SolarWinds Failover Engine post-installation plug-in install procedures.


D. Upgrade Plug-ins

NOTE: This is performed by uninstalling the old versions of plug-ins and reinstalling the new ones on the active server. Installation of a plug-in on a passive server may cause an Exception to occur.

  1. On the Primary/active server, launch the SolarWinds Failover Engine Management Client.
  2. To uninstall the old plug-in, navigate to Applications: Plug-ins , and select the desired plug-in to be removed/uninstalled.
  3. Click on the Uninstall button in the Plug-ins pane.

    Note: When the plug-in is uninstalled, the files are not removed. They are left in “<Heartbeat install dir>\R2\plugins” folder.
  4. To install the new plug-in, navigate to Application: Plug-ins , then click on the Install button.
  5. Click the Browse button and navigate to the <Heartbeat install dir>\R2\<version> plug-ins\<plug-in name> location.
  6. Select the *NFPlugin.dll file, then click OK to complete the installation (for example, SqlServerNFPlugin.dll for SQL Server plug-in or SystemNFPlugin.dll for the System Plug-in).

Applies To

SolarWinds Failover Engine vx.x.x


Related Information

None

KBID-2627

0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.