Uninstalling and Immediately Reinstalling a Plug-in Causes the Plug-in Installation to Fail

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Summary

This Knowledgebase article provides information about how to resolve the failure of a plug-in to install immediately after uninstalling the plug-in.


More Information

Note: Installation/reinstallation of plug-ins should only be performed on the active server.

Symptom

Uninstalling a plug-in and immediately reinstalling or installing an upgraded version of the plug-in results in failure of the plug-in to install.

Cause

When uninstalling a plug-in, the plug-in must be uninstalled from both the active and passive server. Sufficient time must elapse for Neverfail to complete the uninstall process before an attempt is made to reinstall the same or an upgraded version of the plug-in.

Resolution

To prevent failure during the installation of the same or an upgraded version of the plug-in, wait until the "Unloaded Plugin" message from both the active and passive server are visible in the Neverfail Application Log. Once both messages are visible, install/reinstall the plug-in.


Applies To

Neverfail Heartbeat V5.3.0


Related Information

None

KBID-1385

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