SolarWinds - System Crash (Stop Error) 0x7B, Inaccessible Boot Device on Windows Server 2008 - Alternate Solution

Follow

Summary

This Knowledgebase article describes how to troubleshoot System Crash (Stop Error) 0x7B, Inaccessible Boot Device errors on Windows Server 2008 and when installing SolarWinds Failover Engine on Windows Server 2008 with different disk sub-systems.


More Information

Symptoms

When SolarWinds Failover Engine is restarted following a restore on the Secondary server, the Secondary server stops with the following error message:

System Crash (Stop Error) 0x7B, Inaccessible Boot Device

Cause

This error occurs when the system disks on the Primary and the Secondary servers have different disk/RAID controllers.

Resolution

NOTE: Every volume that will be restored on the Secondary must be equal to or larger than the corresponding volume present on the Primary. The actual space used on the volume is of no relevance.

Procedure #1: Local Backup

The backup folder is copied from the Secondary server on a different disk than the disk containing the system volume (may be a removable disk).

  1. Locate the folder designated to store the SolarWinds Failover Engine backup, for example, D:\SWFoEBackup.
    Inside this folder are the WindowsImageBackup folder and a few other files.
  2. Copy only the WindowsImageBackup folder on a root drive (D:\ or E:\) to a disk that does NOT contain the C:\ partition, for example, D:\WindowsImageBackup

    NOTE: The Backup folder ( WindowsImageBackup ) should be on a volume that is not part of the disk containing the system volume because at Step 8 you will be prompted to Format and repartition disks and you cannot format the disk that contains the partition with the backup folder).
  3. Start the Secondary server from the Windows 2008 DVD.
  4. Choose Repair .
  5. The existing instance of Windows 2008 should be detected.  Click Next .
  6. Select Windows Complete PC Restore .
  7. The next step detects the location of the WindowsImageBackup folder copied in Step 2. For example, if it was copied on the D:\ drive (D:\WindowsImageBackup), this should return the D: drive location.
    Click Next .
  8. Select Format and repartition disks and click Exclude disks .
  9. Exclude all disks other than the disk that contains the System volume.
  10. Click Finish and allow for the restore process to complete.
  11. After the server is restarted, a black screen may appear (not a blue screen) with the following error message: \Boot\BCD error message : An error occurred while attempting to read the boot configuration data : http://support.microsoft.com/kb/927391
  12. To resolve this error, restart from the Windows 2008 DVD.
  13. Select Repair .
  14. Select Command Prompt .
  15. Run the following command: Bootrec /RebuildBcd

Procedure #2: Network Backup

The backup is present on a different server (could be the Primary or any other server on the network) that is reachable from the Secondary server using DHCP IP settings.

  1. Start the Secondary server from the Windows 2008 DVD.
  2. Select Repair .
  3. The existing instance of Windows 2008 should be detected, click Next .
  4. Select Windows Complete PC Restore .
  5. Select Restore a different backup and click Next .
  6. Click Advanced .
  7. Select Search for a backup on the network .
  8. Click Yes .
  9. Enter the location path of the backup folder.
    For example, if the WindowsImageBackup folder is located on the E: drive, the path should be: \\<server>\E$
  10. Select the location of the backup and click Next .
  11. Select the backup to restore and click Next .
  12. Select Format and repartition disks and click Exclude disks .
  13. Exclude all the disks except for the disk that contains the System volume.
  14. Click Finish and allow for the restore process to complete.
  15. After the server is restarted, a black screen may appear (not a blue screen) with \Boot\BCD error message : An error occurred while attempting to read the boot configuration data. See http://support.microsoft.com/kb/927391
  16. In order to fix this error, restart from the Windows 2008 DVD.
  17. Select Repair .
  18. Select Command Prompt .
  19. Run the following command: Bootrec /RebuildBcd

Additional information

After the last restart, Windows may have problems with the TCP/IP stack. To resolve this issue, perform the following steps

  1. Open a Command Prompt.
  2. Run the following command: sfc /scannow
  3. Restart the server.

Applies To

Windows Server 2008 (except R2)


Related Information

Knowledgebase Article #456 System Crash (Stop Error) 0x7B, Inaccessible Boot Device

Knowledgebase Article #1775 System Crash (Stop Error) 0x7B, Inaccessible Boot Device on Windows Server 2008

Knowledgebase article #1883 - How to Recover from System Crash 0x7B using Symantec Backup Exec System Recovery 2010

Microsoft Support article — Error messages when you try to gain access to an NTFS volume

Microsoft Support article — Error message when you start Windows Vista: "The Windows Boot Configuration Data file is missing required information"

KBID-2589

0 out of 0 found this helpful

Comments

0 comments

Please sign in to leave a comment.