The SQL Server Plug-in is only able to provide automatic protection for the MSDT.log file; it is unable to replicate the configuration information used by Windows. If the log file location is changed, the Administrator must reconfigure MSDT on the passive server before switching over. This Knowledgebase article provides information about how to resolve the problem of the MSDTC service failing to start because the configuration information is incorrect on the passive.
Symptom
After changing the location of the MSDTC.log file location on the active server, performing a switchover, and running the File Filter Discovery task on the new active server, the MSDTC.log file location is not protected on the new active server and the Distributed Transaction Coordinator (MSDTC) service will fail to start.
Cause
Neverfail for SQL Server Plug-in provides automatic protection of the MSDTC.log file ensuring replication to the passive server(s). It does not however replicate the MSDTC.log file location information to the passive server(s). If the location of the MSDTC.log file is changed, you must manually update the passive server MSDTC.log file location information with the new location.
Resolution
This procedure should be performed to be able to change the location of the MSDTC.log file on the active and passive server(s).
To update the passive server(s) MSDTC.log file location:
SQL Server Plug-in