Continuity Engine Troubleshooting - Application Slowdowns

Continuity Engine Troubleshooting - Application Slowdowns

This artcle discusses application slowdowns that you may encounter under routine operations. Neverfail Continuity Engine is designed to provide robust continuous application support and a slowdown of protected applications is considered an abnormal or unexpected behavior. 
Applications Slowdown

Learning objectives 

At the completion of this session you should be able to:
  1. Identify the symptoms of an application slowdown.
  2. Identify the causes of an application to slow down.
  3. Recall how to correct an application slow down.

Overview

Application slowdowns can have a negative impact on an organization's effectiveness and become a major source of frustration for end users.

Symptoms

Indications of application performance problems include an application that starts running slowly on the active server, users complaining about a protected application taking a long time to process requests, high CPU utilization, and the buildup of data in the send or receive cues. 

Causes

The most common causes of application slowdowns are:
  1. Insufficient Windows resources.
  2. Inadequate hardware (for example, low free physical RAM that leads to excessive paging to disk, or disk sub-system bottlenecks).
  3. Rapid updates to protected files while doing a full system check.
  4. A slow WAN channel connection.
  5. Excessive file filters (normally a symptom of too many file shares) .
  6. Poorly configured applications. 

Resolutions

Most application performance problems are caused by either hardware that is not up to the task, or improperly configured hardware and software. 
To avoid poor application performance Neverfail recommends that you do the following: 
  1. Run SCOPE before installation of Neverfail Continuity Engine. Acting upon the recommended changes contained in the SCOPE report will assist in resolving many of the potential issues.
  2. Ensure that your hardware meets Neverfail Continuity Engine recommended minimum requirements.
  3. Follow manufacturer recommendations on hardware and software configuration.
  4. Verify that you are using the latest hardware drivers.
  5. Ensure disk sub-systems are similar on all servers.
  6. Schedule resource intensive tasks such as database defragmentation during off peak hours.
More information about application slowdowns is located in the Neverfail Knowledge Base. 

Wrap Up

This article discussed application slowdowns that you may encounter under routine operations. Remember these key points:
  1. Symptoms:
    1. The symptoms of an application slowdown include an application that starts running slowly on the active server. 
    2. Users complaining about a protected application taking a long time to process requests.
    3. High CPU utilization.
    4. A buildup of data in the Send or Receive queues.
  2. Causes: 
    1. Insufficient Windows resources.
    2. Inadequate hardware.
    3. Rapid updates to protected files while doing a full system check. 
    4. Slow WAN connection.
    5. Excessive fire filters.
    6. Poorly configured applications. 
  3. Resolution to prevent or resolve application slowdown:
    1. Run SCOPE prior to installation of Neverfail Continuity Engine.
    2. Act upon recommended changes.
    3. Ensure that your hardware meets Neverfail Continuity Engine recommended minimum requirements.
    4. Follow manufacturer recommendations on hardware/software configuration. 
    5. Verify that you are using the latest hardware drivers.
    6. Ensure disk sub-systems are similar on all servers.
    7. Schedule resource intensive tasks during off peak hours.

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