This adticle introduces you to license related problems that you may encounter durig routine operations.
Invalid License Learning objectives
At the completion of this session you should be able to:
- identify the symptoms of an invalid Neverfail Continuity Engine license.
- Identify the causes of an invalid Neverfail Continuity Engine license.
- Recall how to correct an invalid Neverfail Continuity Engine license.
Invalid License
Neverfail Continuity Engine uses the Heartbeat Signature (HBSIG) in its licensing scheme. The HBSIG consists of eight alphanumeric characters that represent information about your specific machine. Some of the HBSIG represents a Fully Qualified Domain Name (FQDN) and the remaining digits represent the machine SID. Continuity Engine uses the HBSIG to generate your license key. When HBSIG changes, your existing license key becomes invalid.
Symptoms
After changing the name of the server, reinstalling the operating system, moving the server to a different domain, or adding Neverfail Continuity Engine licensed options to a server, Continuity Engine will not start. This is by design and requires the creation of a new Continuity Engine license key.
Causes
The Neverfail Continuity Engine license key is tied to both the FQDN, and the SID, and also to plug-in information on a specific server. If you make a change that affects the HBSIG or add a new plug-in, the Continuity Engine license key becomes invalid.
Resolution
To correct the invalid license key, perform the following:
- Navigate to the management drop-down and click on License > License the selected server.
- If connected to the internet, select Apply license from your Neverfail account, enter your Neverfail credentials, press Next and continue with step 4.
- If there is no internet connection, obtain a license key from Neverfail, select Manually enter a license key, enter the key and press Apply.
- If the key is successfully applied, click Finish. Otherwise review the error message.
- In the select license step, from the table of licenses, select the license to apply based on the features required. Licenses already used for the selected cluster are shown as applied. Click Next.
- Review the summary information and click Next. On the apply license step click Finish.
Expired License
As stated previously, the Neverfail Continuity Engine license key is tied to the fully qualified domain name and to the SID of the server that was assigned during the installation of the operating system. What are the symptoms causes and resolutions for an expired license?
Symptoms
During the course of routine operations, you may experience an occasion where an error message indicates that your license key has expired. This is normally the result of an expired temporary or time limited license.
Causes
Neverfail sometimes provides temporary licenses during implementation if users experience a problem during the installation of Neverfail Continuity Engine software. This allows the implementation to proceed without interruption. If you do not take follow-up action to replace the temporary or time limited license, it will eventually expire.
Resolution
To replace a temporary or time limited license, contact your Neverfail sales representative to obtain a new product license. Once you have a new product license perform the following:
- Navigate to the management drop-down and click on License > License the selected server.
- If connected to the internet, select Apply license from your Neverfail account, enter your Neverfail credentials, press Next and continue with step 4.
- If there is no internet connection, obtain a license key from Neverfail, select Manually enter a license key, enter the key and press Apply.
- If the key is successfully applied, click Finish. Otherwise review the error message.
- In
the select license step, from the table of licenses, select the license
to apply based on the features required. Licenses already used for the
selected cluster are shown as applied. Click Next.
- Review the summary information and click Next. On the apply license step click Finish.
Windows Management Instrumentation
Another reason for which you may receive an invalid license key error is the Windows Management Instrumentation (WMI).
Symptoms
During installation, you may experience an invalid license key error if the WMI service is either not running or hung.
Causes
If WMI service is not running or is hung, Continuity Engine installation cannot complete.
Resolutions
To troubleshoot an invalid license key error during installation, check the Windows Services to see if the WMI service is running. If not, start the service.
If WMI is running, restart WMI to ensure that it is not hung and continue your installation of Neverfail Continuity Engine.
Wrap Up
This article discussed occurrences of an invalid Neverfail Continuity Engine license key. Remember the following key points:
- The symptoms of an invalid Neverfail Continuity Engine license key included failure of Neverfail Continuity Engine to install and failure of Neverfail Continuity Engine to start.
- The causes of an invalid license key consist of an expired license key, changes affecting the HBSIG, or problems with the WMI service.
- Resolve an invalid license key by obtaining a new license key or checking the WMI service.