This artucke introduces you to MaxDiskUsage errors when using Neverfail Continuity Engine. Continuity Engine generates MaxDiskUsage errors when either the send or receive queues are full.
MaxDIskUsage Errors Learning objectives
At the completion of this session you should be able to:
- Identify the symptoms of MaxDiskUsage errors.
- Identify the causes of MaxDiskUsage errors.
- Recall how to correct MaxDiskUsage errors.
Overview
Send and Receive queues are typically located in RAM but will use physical desk in certain circumstances. If a passive server becomes unavailable and the Send queue fills, it will eventually spill over onto disk. Furthermore, if WAN Compression or Acceleration has been enabled, RAM is bypassed and all data is queued directly to disk.
Neverfail Continuity Engine sets a default limit of 10 Gigabytes of disk space for each of the Send and Receive queues. If the Send or Receive queues are using the disks to store data, and either the Send queue or the Receive queue exceeds the configured size, a MaxDiskUsage error is generated. MaxDiskUsage errors tell you that your Send or Receive queue limit has been exceeded and intervention is necessary to prevent data loss.
Symptoms
MaxDiskUsage errors will normally be causing application slowdowns. Users will detect this as slowdown of protected application response. With alerts properly configured, Neverfail Continuity Engine can notify system administrators immediately if an established threshold is exceeded.
Causes
Primarily MaxDiskUsage errors are generated as a result of the following.
- Bottlenecks caused by:
- inadequate bandwidth.
- Excessive replication traffic on the Neverfail Channel (such as performing database the fragmentation during replication).
- Disk drives out of space resulting from:
- Available disk space less than the queue size.
- Passive server(s) disk drives smaller than the active server.
Most MaxDiskUsage errors are preventable by using Neverfail Continuity Engine recommended configuration processes.
Resolutions
You can avoid MaxDiskUsage errors by ensuring that server/host hardware in available bandwidth are up to the task. Meeting or exceeding minimum hardware and software requirements helps prevent MaxDiskUsage errors.
Properly configuring Neverfail Continuity Engine provides optimum performance thereby preventing application slowdowns.
Finally, you can avoid MaxDiskUsage errors by performing the steps below:
- Ensure that the available disk space on the hard drives of the active and passive server exceeds the configured to send and receive queue size. The default configuration for a pair of servers requires 10 gigabytes of disk space on the active and passive servers. For a trio, this space requirement is doubled.
- Verify that the passive servers disk space is equal to or greater than the active server to ensure that the data demands of the active server do not exceed the capacity of the passive server.
- Ensure that Neverfail Continuity Engine log directory is hosted on its own disk or one that does not store protected application data or the Windows system folder.
Additional information about MaxDiskUsage errors is available in the Neverfail Knowledge Base.
Wrap Up
This artiucle discussed MaxDiskUsage errors. Remember these key points:
- The symptoms of MaxDiskUsage errors include application slowdowns.
- The causes of MaxDiskUsage errors include:
- Inadequate bandwidth.
- Excessive replication traffic.
- Insufficient available disk space.
- Using a smaller disk drive on the passive server(s) then on the active server.
- To prev
- ent MaxDiskUsage errors ensure:
- Hardware and available bandwidth are up to the task.
- Check available disk space on both the active and passive servers exceed the configured queue sizes.
- Verify that the passive servers disk space is equal to or greater than that of the active server.
- Ensure that the never fail continuity engine log directory is hosted:
- On its own disk.
- One that does not host protected application data or the windows system folder.