Summary
This Knowledgebase article provides procedures for upgrading an application protected by Neverfail Engine in a Pair configuration.
This KB article is for applying service packs, patches and hotfixes and not major version application upgrades.
Notes:
- Prior to attempting this upgrade, you should read the entire procedure.
- This procedure requires downtime as it involves a series of switchover between Primary and Secondary servers so you might want to schedule a maintenance window for doing it.
- The procedure starts by applying the application service packs/rollups on the Secondary server first so that in case that process fails, your Primary server remains untouched and can be used as before by simply remaking it Active.
- Prior to updating check the release notes of the Neverfail plug-in for your protected application and make sure it supports the new application version or Service Pack.
Procedure
On the Active Server
Note: If the Secondary server is the active server, please omit step 1. below.
- Using the Neverfail Advanced Management Client, perform a switchover by clicking the Make Active button. Wait for the Secondary server to become active.
On the Secondary (now Active) Server
- Using the Shutdown Group option in the Neverfail tray icon, shutdown Neverfail Engine on the Secondary (active) and Primary server leaving the protected applications running.
Pair status: Secondary active with Engine stopped and application running and Primary passive with Engine and applications stopped.
- If upgrading the Application to a later update:
- Install the Application Update by running its setup program/service pack.
- If asked, reboot the server at this point.
- Verify that Application is operational.
- If the server was rebooted, shutdown Neverfail Engine on the Secondary server.
- If the upgrade procedure was successful proceed to the next step, else goto "upgrade failed".
- Change the server role to Secondary/passive. To do this please perform the steps below:
- Launch the Neverfail Configure Server Wizard and click on the Machine tab. Change the Active Server to be the Primary.
- Using the Windows Service Control Manager, start Neverfail Engine service.
- Wait until Engine stops all the services of the protected application. This can be checked/seen under Application/Services section of the Neverfail Advanced Management client.
- Using the Windows Service Control Manager, stop Neverfail Engine service.
On the Primary Server (Assuming a successful upgrade of Secondary completed):
- Make sure the Primary role is now Active.
- Launch the Neverfail Configure Server Wizard and click on the Machine tab. Change the Active Server to be the Primary.
- Using Windows Service Control Manager, start Neverfail Engine service.
- Wait until all services of the protected application are started.
- Using the Shutdown Engine option, shutdown Neverfail Engine on the Primary (now active) server leaving the protected applications running.
- If upgrading the Application to a later update:
- Install the Application Update by running the setup program/service pack.
- If asked, reboot the server at this point.
- Verify that Application is operational.
- If the upgrade procedure was successful proceed to the next step, else goto "upgrade failed".
- Start Neverfail Engine on the Primary Server.
- Finalising Upgrade:
- Start Neverfail Engine on the Secondary server.
- Using the Neverfail Advanced Management Client:
- Under Applications\Tasks section verify that the Protected Service Discovery task from under the section of your protected application has run.
- Check that the system completes the Full System Check.
- If the upgrade on Secondary/Primary server fails:
- Research the cause of the upgrade failure.
- If the issue can be resolved then it is safe to proceed with the upgrade procedure. Otherwise, you can revert to the previous version.
- To revert to a previous version:
- Uninstall the upgraded components and check the application starts after the rollback.
- On the Secondary server, launch the Neverfail Engine Configure Server Wizard and click on the Machine tab. Change the Active server to be Primary.
- Reboot the server.
- Neverfail Engine will start and the Application will be stopped.
- On the Primary server, launch the Neverfail Engine Configure Server Wizard and click on the Machine tab. Change the Active server to be the Primary.
- Restart Neverfail Engine on the Primary Server and allow the system to synchronise.
- Using the Neverfail Advanced Management Client, check that the system starts and completes the Full System Check.
- Investigate the cause of the application upgrade failure on the Secondary server.
Note: In the event of the server connecting to a remote database (DB) you should create backups at key points of the patching process in the event of DB structure changes.
- Backup the remote DB before upgrading on Secondary
- Backup the remote DB again after upgrading on Secondary (when upgrade successful)
- Restore the remote DB to the pre-upgrade point BEFORE starting the upgrade on the Primary (before starting Step 5)
Applies To
Customer Applications
Neverfail Engine
None
KBID-3003