Neverfail Continuity Engine Synchronization Failures

Neverfail Continuity Engine Synchronization Failures

Summary

This Knowledgebase article provides information about how to resolve Neverfail Continuity Engine synchronisation failures including the symptoms, causes, and resolutions.

More Information

When Neverfail Continuity Engine is started, a Full System Check occurs. This ensures that:
  1. All protected File/Folder structure from the active server is present on the passive server
  2. All protected Registry Keys and values from the active server are present on the passive server

After the Full System Check finishes, the File System Status and the Registry Status should both be shown as Synchronised. However, there may be cases when the
File System Status or the Registry Status are shown as Out-of-Sync or Synchronised and busy processing. Some of the cases are described below, with possible
reasons and workarounds.

Services Running on the Passive Server

Symptoms

File System Status is Out-of-Sync or Synchronised and busy processing

Cause

A service that is running on the passive server may open a protected file for exclusive access. If Neverfail Continuity Engine attempts to update a file that was opened in this way, the following error is logged by the Apply component:
[N29]The passive Neverfail server attempted to access the file: {filename}. This failed because the file was in use by another application. Please ensure that there are no applications which access protected files running on the passive.
Services that keep files locked on the passive server include:
  1. Protected application services
  2. Antivirus services
  3. The NNTP service in a Neverfail for IIS deployment (if the %\Inetpub folder is shown as Out-of-Sync)
  4. IISAdmin service in a Neverfail for IIS deployment (if the C:\WINDOWS\system32\inetsrv\Metabse.xml is shown as Out-of-Sync)
  5. IISAdmin service starts on the passive after a reboot of the server and must be stopped manually
  6. Print Spooler service (if C:\WINDOWS\system32\spool\drivers is shown as Out-of-Sync)
  7. MSDTC service (if C:\WINDOWS\system32\MsDtc\MSDTC.LOG is shown as Out-of-Sync)

Resolution

Until the file is closed on the passive server, Neverfail Continuity Engine reports the file status, and hence the File System Status, as Out-of-Sync.
To resolve an Out-of-Sync system status, take the actions below:
  1. Ensure Protected Application services are set to Manual on both servers and that they are not running on the passive server.
  2. Ensure that the Recovery Actions set from the Service Control Manager (SCM) for the Protected Application services are set to Take No Action (otherwise, the Protected Application services will be restarted by the SCM).
  3. Ensure that your Antivirus is not part of the protected set as the antivirus and the corresponding services are running on both machines. See Knowledgebase Article #104 - Neverfail and Anti-Virus Tools - General Advice Regarding Interoperability with AntiVirus Scanners.
  4. Ensure the NNTP service is not running on the passive server in a Neverfail for IIS deployment (if the \Inetpub folder is shown as Out of Sync). This is valid for some of the Exchange implementations as well, where IIS Admin is protected.
  5. Ensure that IISAdmin is not running on the passive server in a Neverfail for IIS deployment (if the file C:\WINDOWS\system32\inetsrv\MetaBase.xml is Out-of-Sync).

Neverfail Channel Incorrectly Configured

Symptoms

If the Neverfail Channel is not properly configured, it cannot initiate the handshake which establishes communications through the channel connection. Failure to establish the channel connection will prevent a Full System Check thereby leaving the File System Status and Registry Status as Out-of-Sync.

Cause

The most common Neverfail Channel configuration errors are:
  1. Channel IP addresses configured in different subnets
  2. In a WAN implementation, no static routes between the channel NICs

Resolutions

To resolve a Neverfail Channel configuration error:
  1. Verify that channel IP addresses are properly configured
  2. In a WAN implementation, verify that static routes between channel NICs are properly configured
  3. Ensure that NetBIOS settings on the channel NICs have been disabled

The Passive Server has Less Available Space than the Active Server

Symptoms

Replication will stop and the following error is reported:
[N27]Failed to write information for the file: {filename} to the disk. Either the disk is full or the quota (for the SYSTEM account) has been exceeded.

Cause

The passive server has less available disk space than the active server, preventing updates from being replicated to the passive server, because the quantity of updates from the active server exceed the passive server's available disk space.

Resolution

Free up some additional disk space on the passive server. Make sure you are not deleting data from the protected set as you might lose data in the event of a switchover. You may need to update the disk subsystem on the passive server. Once complete, you will need to start replication.

Unprotected File System Features

Symptoms

Another possible reason why Neverfail Continuity Engine cannot synchronise certain files or directories is the presence in the replication set of so-called "unprotected" file system features.
The default behaviour for Neverfail Continuity Engine in the presence of Unprotected Features from category 2 (Extended Attributes and file encryption) is to log an error and set the File System Status to Out-of-Sync. If these types of files are present in the replication set, replication continues, but the system will remain Out-of-Sync.

Cause

Neverfail Continuity Engine will not synchronise if the replication set contains files with unprotected file system features.

Resolution

Two methods of dealing with these Unprotected Features are described in KB Article #321 — Neverfail for File Server: Unprotected Features of the Windows NTFS File System. If these features are not essential for the normal operation of your file system, zipping and unzipping the affected files within their parent directory should remove the Unprotected Features, allowing the Neverfail Continuity Engine to synchronise the file system.

Third-Party Applications

Symptoms

Folders appear as Out-of-Sync (e.g. C:\, C:\Windows, C:\Documents and Settings) even when there isn’t any particular file in the folder that is out of sync.

Cause

McAfee Access Protection is designed to prevent changes to the file system, registry hives, and various system components (IP Addresses etc.). While this feature of the McAfee AV product suite is enabled, it will prevent the Neverfail Continuity Engine from walking the common folders described in the Symptoms section above. This will cause this folders to be marked as locked resulting in an out of sync status within Neverfail Continuity Engine.

Resolution

McAfee OnAccess Protection has to be permanently disabled from the VirusScan console. This change will need to be implemented on all servers in the set(s).

Registry Status is Out of Sync

If one or more Registry keys fail to synchronise the Registry may be reported as Out-of-Sync. There are at least two possible reasons for this, resource issues and registry security issues.

Resource Issues

Symptoms

Neverfail Continuity Engine logs the following error message:
Call to RegOpenKeyEx failed: on <Reg_Key> : Insufficient system resources exist to complete the requested service.

Causes

One or both of the servers are running low on virtual memory.

Resolutions

This is usually a sign that the server does not have enough available virtual memory. A restart of the server should correct this problem.

Registry Security Issues

Symptoms

Neverfail is unable to read/sync/replicate the registry.

Causes

If a protected registry key has permissions that deny Write access to the System account, Neverfail Continuity Engine may be unable to synchronise or replicate it.

Resolutions

Change the permissions on the affected registry key to grant the System account Full Control.
NOTE: Some Antivirus solutions prevent any writes at the registry level, so even if Neverfail Continuity Engine has the required permissions it cannot synchronise the registry.

Applies To

Neverfail Continuity Engine

Related Information

None

KBID-2949
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